Given a non-empty tree with root R, and with weight W​i​​ assigned to each tree node T​i​​. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let's consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S<2​30​​, the given weight number. The next line contains N positive numbers where W​i​​ (<1000) corresponds to the tree node T​i​​. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A​1​​,A​2​​,⋯,A​n​​} is said to be greater than sequence {B​1​​,B​2​​,⋯,B​m​​} if there exists 1≤k<min{n,m} such that A​i​​=B​i​​ for i=1,⋯,k, and A​k+1​​>B​k+1​​.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

Special thanks to Zhang Yuan and Yang Han for their contribution to the judge's data.

我的思路:

1. 建立结构体,存储权值,还有孩子。

2. 进行dfs,中间要加入权重值和的计算判断。 

3. 进行代码实现的时候,dfs又把自己绕晕进去...我好想哭啊,递归怎么这么难写...下午按照柳神的思路再写一遍把!

柳神:

1. 在录入树的结点的时候就进行排序,以便深搜的时候直接从大到小输出。第一次见到这种cmp函数的书写方式诶,感觉学到了!!

2. 还有就是控制输出那个地方,也很新奇,值得学习!

3. path数组,传入一个nodeNum记录对当前路径来说这是第几个结点(这样直接在path[nodeNum]里面存储当前结点的孩子结点的序号,这样可以保证在先判断return的时候,path是从0~numNum-1的值确实是要求的路径结点)。然后每次要遍历下一个孩子结点的之前,令path[nodeNum] = 孩子结点的序号,这样就保证了在return的时候当前path里面从0~nodeNum-1的值就是要输出的路径的结点序号,输出这个序号的权值即可,直接在return语句里面输出。

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
int target;
struct NODE {int w;vector<int> child;
};
vector<NODE> v;
vector<int> path;
void dfs(int index, int nodeNum, int sum) {if(sum > target) return ;if(sum == target) {if(v[index].child.size() != 0) return;  //没有到叶子结点,返回for(int i = 0; i < nodeNum; i++) //到了叶子结点并且权值一样,进行输出printf("%d%c", v[path[i]].w, i != nodeNum - 1 ? ' ' : '\n');return ;}for(int i = 0; i < v[index].child.size(); i++) {  //递归访问孩子结点int node = v[index].child[i];path[nodeNum] = node;dfs(node, nodeNum + 1, sum + v[node].w);}}
int cmp1(int a, int b) {return v[a].w > v[b].w;
}
int main() {int n, m, node, k;scanf("%d %d %d", &n, &m, &target);v.resize(n), path.resize(n);for(int i = 0; i < n; i++)scanf("%d", &v[i].w);for(int i = 0; i < m; i++) {scanf("%d %d", &node, &k);v[node].child.resize(k);for(int j = 0; j < k; j++)scanf("%d", &v[node].child[j]);sort(v[node].child.begin(), v[node].child.end(), cmp1);}dfs(0, 1, v[0].w);return 0;
}

PAT甲级 -- 1053 Path of Equal Weight (30 分)相关推荐

  1. PAT甲级1053 Path of Equal Weight (30分) :[C++题解]dfs求树的路径长度、邻接表

    文章目录 题目分析 题目链接 题目分析 输入样例: 20 9 24 10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2 00 4 01 02 03 04 02 1 ...

  2. PAT (Advanced Level) Practice 1053 Path of Equal Weight (30 分)

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight Wi assigned to ...

  3. 1053 Path of Equal Weight (30分)

    1053 Path of Equal Weight (30分) Given a non-empty tree with root R, and with weight W​i​​ assigned t ...

  4. PAT:1053. Path of Equal Weight (30) AC

    #include<stdio.h> #include<vector> #include<queue> #include<algorithm> using ...

  5. 1053 Path of Equal Weight

    1053 Path of Equal Weight (30 分) Given a non-empty tree with root R, and with weight W​i​​ assigned ...

  6. PAT甲级1127 ZigZagging on a Tree (30分):[C++题解]之字形层次遍历树bfs实现一层一层读入

    文章目录 题目分析 题目链接 题目分析 分析 给定中序遍历和后序遍历,先建树: 后面就是写一个bfs,层序遍历稍微改改即可. bfs要做的修改是如何一层一层的读入.令根结点是第一层,本题的之字形遍历就 ...

  7. PAT甲级1064 Complete Binary Search Tree (30分):[C++题解]完全二叉搜索树BST

    文章目录 题目分析 题目链接 题目分析 思路: 第一步,构造含有n个结点的完全二叉树:第二步,将n个数值填入,使其满足二叉搜索树的性质. 对于第一步: 完全二叉树用一维数组可以存下,不过从根结点的下标 ...

  8. PAT甲级1038 Recover the Smallest Number (30 分):[C++题解]贪心、排列成最小的数、字符串

    文章目录 题目分析 题目来源 题目分析 来源:acwing 分析: 贪心: 对于字符串a和b,如果 a+b < b+a (这里+代表字符串中的连接)代表字典序更小.举例 a = 321 , b ...

  9. 1053 Path of Equal Weight (30 分)

    题目 Given a non-empty tree with root R, and with weight WiW_iWi​ assigned to each tree node TiT_iTi​. ...

最新文章

  1. 利用JS中window.showModalDialog()详解
  2. 皮一皮:是亲爹的操作 ,没错...
  3. 【Linux 内核 内存管理】优化内存屏障 ① ( barrier 优化屏障 | 编译器优化 | CPU 执行优化 | 优化屏障源码 barrier 宏 )
  4. 【STM32】跑马灯实验主要程序代码分析
  5. 看雪学院课程《汇编语言详解与二进制漏洞初阶》笔记
  6. django邮箱验证模块
  7. 【笔记】 感受野与权值共享 摄像头标定 相机坐标与世界坐标
  8. python模糊图像清晰化_视频模糊图像处理
  9. python独立图形_在networkx中查找图形对象中的独立图形
  10. 【BZOJ1188】分裂游戏,博弈
  11. swift. 扩展类添加属性_swift 扩展属性的方法
  12. java开发16g内存够吗_Java 内存模型 ,一篇就够了!
  13. 移动吉比特H2-2光猫超级用户与密码
  14. 30岁前如何规划自己的人生?这9本书告诉你
  15. c语言26字母排序,C语言,26个字母的冒泡排序
  16. 上井冲刺港交所上市:人均消费金额降幅明显,只在中国经营业务
  17. 百度云服务器BCC centos实例搭建vsftpd站点
  18. 清华大学计算机系女生人数,2013年清华大学在各省市录取人数及男女比例
  19. [198].打家劫舍
  20. 关于防止表单重复提交

热门文章

  1. Websniff -aspx网页嗅探工具及使用说明
  2. dy之xgorgon0404参数
  3. 五分钟快速理解 Reactor 模型
  4. JAVA线程间协作:wait.notify.notifyAll
  5. 音视频技术开发周刊(第126期)
  6. 张睿:OpenH264拥有产品级的鲁棒性 欢迎contribute
  7. 利用linux的df和du命令查看文件和目录的内存占用
  8. ffmpeg与ffserver的协同工作
  9. RTMP的URL/Vhost规则
  10. Kafka,它为什么速度会这么快?