PPP有两种认证协议一种是pap协议,一种chap协议。

在安全性上chap协议安全性高。pap协议传输时password是明文的,认证用户名和密码可以不一致chap在传输过程中不传输明文,而是用hash哈希值)来取代,质检握手身份核实(密码被隐藏)--在chap双方认证中,双方密码必须保持一致,否则认证失败

pap认证是通过两次握手实现的,而chap是通过三次握手实现。

实验拓扑搭建

  注意:路由器间应使用Serial线相连

设备编址

IP gateway
PCA 192.168.1.2/30 192.168.1.1
PCB 192.168.2.2/30 192.168.2.1
Router! 10.1.1.1/30
Router2 10.1.1.2/30

在RA上配置PPP

<H3C>system-view
System View: return to User View with Ctrl+Z.
[H3C]interface Serial 1/0
[H3C-Serial1/0]link-protocol ppp
[H3C-Serial1/0]ip address 10.1.1.1 255.255.255.252
[H3C-Serial1/0]baudrate 2048000
[H3C-Serial1/0]quit[H3C]interface g0/0
[H3C-GigabitEthernet0/0]ip address 192.168.1.1 255.255.255.252
[H3C-GigabitEthernet0/0]undo shutdown

查看此时RA的信息

[H3C]display interface Serial 1/0
Serial1/0
Current state: UP
Line protocol state: UP
Description: Serial1/0 Interface
Bandwidth: 64 kbps
Maximum transmission unit: 1500
Hold timer: 10 seconds, retry times: 5
Internet address: 10.1.1.1/30 (Primary)
Link layer protocol: PPP
LCP: opened, IPCP: stopped
Output queue - Urgent queuing: Size/Length/Discards 0/1024/0
Output queue - Protocol queuing: Size/Length/Discards 0/500/0
Output queue - FIFO queuing: Size/Length/Discards 0/75/0
Last link flapping: 0 hours 6 minutes 10 seconds
Last clearing of counters: Never
Current system time:2022-08-26 16:36:36
Last time when physical state changed to up:2022-08-26 16:30:26
Last time when physical state changed to down:2022-08-26 16:30:18

在RB上配置PPP

<H3C>system-view
System View: return to User View with Ctrl+Z.
[H3C]interface Serial 1/0
[H3C-Serial1/0]link-protocol ppp
[H3C-Serial1/0]ip address 10.1.1.2 255.255.255.252
[H3C-Serial1/0]quit[H3C]interface g0/0
[H3C-GigabitEthernet0/0]ip address 192.168.2.1 255.255.255.252
[H3C-GigabitEthernet0/0]undo shutdown

也可以查看此时的RBSerial1/0信息

[H3C]display interface Serial 1/0
Serial1/0
Current state: UP
Line protocol state: UP
Description: Serial1/0 Interface
Bandwidth: 64 kbps
Maximum transmission unit: 1500
Hold timer: 10 seconds, retry times: 5
Internet address: 10.1.1.2/30 (Primary)
Link layer protocol: PPP
LCP: opened, IPCP: opened
Output queue - Urgent queuing: Size/Length/Discards 0/1024/0
Output queue - Protocol queuing: Size/Length/Discards 0/500/0
Output queue - FIFO queuing: Size/Length/Discards 0/75/0
Last link flapping: 0 hours 9 minutes 43 seconds
Last clearing of counters: Never
Current system time:2022-08-26 16:40:09
Last time when physical state changed to up:2022-08-26 16:30:27
Last time when physical state changed to down:2022-08-26 16:30:24

配置静态路由

RA上的静态路由

[H3C]ip route-static 192.168.2.0 255.255.255.252 10.1.1.2

RB上的静态路由

[H3C]ip route-static 192.168.1.0 255.255.255.252 10.1.1.1

配置PCIP

测试此时的连通性

PCA ping RA

PCA ping  PCB

配置认证方式

认证方式一:PAP

RA上配置用户,被认证的用户为RB

[H3C]local-user RB class network
New local user added.
[H3C-luser-network-RB]service-type ppp
[H3C-luser-network-RB]password simple pwdpwd
[H3C-luser-network-RB]qu
[H3C]interface Serial 1/0
[H3C-Serial1/0]ppp authentication-mode pap
[H3C-Serial1/0]ip address 10.1.1.1 255.255.255.252
[H3C-Serial1/0]shutdown
[H3C-Serial1/0]%Aug 26 21:49:26:715 2022 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface Serial1/0 changed to down.
%Aug 26 21:49:26:715 2022 H3C IFNET/3/PHY_UPDOWN: Physical state on the interface Serial1/0 changed to down.
[H3C-Serial1/0]undo shutdown
[H3C-Serial1/0]%Aug 26 21:49:32:328 2022 H3C IFNET/3/PHY_UPDOWN: Physical state on the interface Serial1/0 changed to up.

查看此时的RA

[H3C]display interface Serial 1/0
Serial1/0
Current state: UP
Line protocol state: DOWN
Description: Serial1/0 Interface
Bandwidth: 64 kbps
Maximum transmission unit: 1500
Hold timer: 10 seconds, retry times: 5
Internet address: 10.1.1.1/30 (Primary)
Link layer protocol: PPP
LCP: closed
Output queue - Urgent queuing: Size/Length/Discards 0/1024/0
Output queue - Protocol queuing: Size/Length/Discards 0/500/0
Output queue - FIFO queuing: Size/Length/Discards 0/75/0
Last link flapping: 0 hours 4 minutes 1 seconds
Last clearing of counters: Never
Current system time:2022-08-26 21:53:33
Last time when physical state changed to up:2022-08-26 21:49:32
Last time when physical state changed to down:2022-08-26 21:49:26

 ping测试,此时pingRB并不能ping通

RB上配置认证信息

[H3C]interface Serial 1/0
[H3C-Serial1/0]link-protocol ppp
[H3C-Serial1/0]ppp pap local-user RB password simple pwdpwd
[H3C-Serial1/0]ip address 10.1.1.1 255.255.255.252
[H3C-Serial1/0]shutdown
[H3C-Serial1/0]%Aug 26 22:03:21:323 2022 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface Serial1/0 changed to down.
%Aug 26 22:03:21:323 2022 H3C IFNET/3/PHY_UPDOWN: Physical state on the interface Serial1/0 changed to down.[H3C-Serial1/0]undo  shutdown
[H3C-Serial1/0]%Aug 26 22:03:25:396 2022 H3C IFNET/3/PHY_UPDOWN: Physical state on the interface Serial1/0 changed to up.
%Aug 26 22:03:25:396 2022 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface Serial1/0 changed to up.

查看此时RB的信息

[H3C]display interface Serial 1/0
Serial1/0
Current state: UP
Line protocol state: UP
Description: Serial1/0 Interface
Bandwidth: 64 kbps
Maximum transmission unit: 1500
Hold timer: 10 seconds, retry times: 5
Internet address: 10.1.1.1/30 (Primary)
Link layer protocol: PPP
LCP: opened, IPCP: opened
Output queue - Urgent queuing: Size/Length/Discards 0/1024/0
Output queue - Protocol queuing: Size/Length/Discards 0/500/0
Output queue - FIFO queuing: Size/Length/Discards 0/75/0
Last link flapping: 0 hours 8 minutes 57 seconds
Last clearing of counters: Never
Current system time:2022-08-26 21:58:29
Last time when physical state changed to up:2022-08-26 21:49:32
Last time when physical state changed to down:2022-08-26 21:49:27

ping 测试 ;此时的RA可以与RBping通

PCA ping PCB

认证方式二:chap认证

RA上配置chap

[H3C]local-user RB class network
New local user added.
[H3C-luser-network-RB]service-type ppp
[H3C-luser-network-RB]password simple pwdpwd
[H3C-luser-network-RB]qu
[H3C]interface Serial 1/0
[H3C-Serial1/0]ppp authentication-mode chap
[H3C-Serial1/0]ip address 10.1.1.1 255.255.255.252
[H3C-Serial1/0]shutdown
[H3C-Serial1/0]undo shutdown

RB上配置chap

[H3C]interface Serial 1/0
[H3C-Serial1/0]link-protocol chap
[H3C-Serial1/0]ppp chap local-user RB password simple pwdpwd
[H3C-Serial1/0]ip address 10.1.1.1 255.255.255.252
[H3C-Serial1/0]shutdown
[H3C-Serial1/0]undo  shutdown

测试连通性

OK,这就是PPP协议的简单配置了

HCL(六)—配置PPP相关推荐

  1. 大型企业网络配置系列课程详解(六) --PPP链路的配置与相关概念的理解

    大型企业网络配置系列课程详解(六)<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office&qu ...

  2. 第六章 ppp协议实验

                                第六章 ppp协议实验步骤 <?xml:namespace prefix = o ns = "urn:schemas-micro ...

  3. linux pap认证,配置PPP PAP 认证

    配置PPP PAP 认证: 1. 单向认证:R1启动pap R1为主验证方,R2为被验证方. r1(config)#inter s1/0 r1(config-if)#ip add 202.146.0. ...

  4. 实验六 配置GVRP协议

    目录 实验六 配置GVRP协议 实验要求: 网络拓扑图: 操作步骤: 1.配置交换机,全局启用GVRP 2.配置交换机间接口为trunk类型,并允许所有VLAN通过. 3.接口启用gvrp功能,并配置 ...

  5. 实验十二、十三 配置PPP协议、配置Frame-relay协议

    实验十二     配置PPP协议 要求: 配置PPP协议,实现广域网连接.然后,分别采用PAP和CHAP进行验证,最后启用OSPF协议,实现局域网之间相互通信. 基础配置 为路由器R1.R2设置相应的 ...

  6. HCL实验-配置VLAN+NAT模拟内外网

    文章目录 HCL实验-配置VLAN+NAT模拟内外网 1.网络拓扑图 2.VLAN配置 交换机SW-center 交换机SW-ex 路由器Router 3.NAT配置 文章最后 HCL实验-配置VLA ...

  7. smarty模板引擎总结六配置网站title,keywords,description

    前台样式配置 作用:配置前台一些数据 title,keys,网站的描述,一些css样式 在smarty初始化文件 smarty.inc.php $smarty->config_dir    = ...

  8. 8s yaml 配置生成_接口测试框架实战(六) | 配置的数据驱动

    <Python 测试开发实战进阶>课程,4 个月挑战 BAT 大厂年薪 50W+ Offer,文末加群! 在实际工作中,为了便于维护,对于环境的切换和配置,通常不会使用硬编码的形式完成.在 ...

  9. Oracle Golden Gate 系列十六 -- 配置 GG 安全 说明 与 示例

    由于GoldenGate所需的用户权限较大,而每个GoldenGate进程配置文件中都需要设置该用户和密码用于数据库登陆,出于安全性的考虑,建议将密码进行加密. 官方文档上介绍的加密有如下三种方法: ...

最新文章

  1. 机器学习数据预处理之离群值/异常值:MAD法(绝对值差中位数法)+绝对中位差(Median Absolute Deviation,MAD)
  2. numpy矩阵乘法的解惑
  3. mysqlimport
  4. php 的函数参数值类型限定
  5. 每个软件工程师都应该尝试的5件事
  6. 《深入理解Nginx:模块开发与架构解析》一1.6 Nginx的命令行控制
  7. 若微型计算机在工作时突然断电,16秋《计算机基础》作业1
  8. 15.3D效果,盒阴影和滤镜
  9. 【Java】equals源码分析
  10. idea Terminal配置cmder(增加nodejs,git配置,jdk本地环境)
  11. 异速联显示连接服务器失败,异速联客户端登陆时正在连接服务器
  12. 超好用的卸载工具——geek(免安装)
  13. C#: 数字经纬度和度分秒经纬度间的转换
  14. 量子计算机怎样输入数据,量子计算入门
  15. 寄存器用途和英文全称
  16. 股票中的KDJ三根线分别代表什么?
  17. SQL Server 遇到报错解决办法--更新中
  18. 习题 5.9 编程序找出1000之内的所有完数。
  19. MSYS+MinGW64环境的搭建
  20. Win11安装Android子系统

热门文章

  1. 微信小程序列表点赞功能
  2. 浅谈MEC移动边缘计算
  3. matlab调频解调,(很实用,很好)用MATLAB实现信号的调制与解调调频调相等
  4. GraphPad Prism 9.5.1 医学绘图分析安装使用教程
  5. Bluecms后台任意修改文件getshell
  6. 明星带货能力是不是皇帝的新衣?胡可单周GMV超2400万,如何成为明星主播Top2
  7. python编写人工智能-用Python写一个中国象棋AI?
  8. OpenWrt使用sstp-client(2)
  9. 春运车票还没抢 钱就被骗走了 这些诈骗手段你得留个心
  10. 使用java开发一个股票交易及量化投资回测分析系统