题干:

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

CTU Open 2003

题意:

给出 n 种卡车,每种卡车的类型是由七个字符组成的,一种卡车可以从另一种卡车派生而来,所需要的代价是两种卡车类型不同的字符个数,求出这 n 种卡车派生的最小代价, n 种车有一 种是开始就已经有的,其余的 n-1 种是派生出来的。

用一个7位的string代表一个编号,两个编号之间的distance代表这两个编号之间不同字母的个数。一个编号只能由另一个编号“衍生”出来,代价是这两个编号之间相应的distance,现在要找出一个“衍生”方案,使得总代价最小,也就是distance之和最小。

解题报告:

读入字符串后先将字符串处理一下,并将权值算好后 入node结构体,然后对结构体排序等等 就是最小生成树裸题了。

ac代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
const int MAX = 10000 + 5 ;int f[MAX+5];
int n;
char s[MAX + 5][10];
int ans;
int top;
struct Node {int u,v,dist;
} node[50000000 + 5];int getf(int v) {return f[v] == v ? v : f[v] = getf(f[v] );
}
void merge(int u, int v) {int t1 = getf(u );int t2 = getf(v );if(t1 != t2) {f[t2] =t1;}}
bool cmp(const Node & a,const Node & b) {return a.dist<b.dist;
}
int main()
{int sum;while(scanf("%d",&n) && n ) {for(int i = 0 ; i<=n; i++) {f[i]=i;}ans = 0;top = 0;for(int i = 1; i<=n; i++) {scanf("%s",s[i]);}for(int i = 1; i<=n; i++) {for(int j = 1; j<=n; j++) {sum = 0;for(int k = 0 ; k<7; k++) {if(s[i][k]!=s[j][k] ) sum++;}++top;node[top].u = i;node[top].v = j;node[top].dist = sum;
//              merge(i,j);}}sort(node+1,node+top+1,cmp);int m=0;//代表边数 for(int i = 1; i<=top; i++) {if(getf(node[i].u) != getf(node[i].v) ) {ans +=node[i].dist;merge(node[i].u,node[i].v);m++;if(m== n-1) break;}}printf("The highest possible quality is 1/%d.\n",ans);          }return 0 ;}

总结:

1.这波太难受了啊。

1RE。因为读字符串的时候i<=MAX了!这样是不对的,因为开的数组大小是MAX所以这里不能小于等于!所以最好就是读数据的时候写<=n,别太洋气的写<=MAX,如果要这么写的话,你开数组就得写MAX+c了!并且发现top和ans没有初始化。

2RE。因为数组开小了。node数组应该开MAX*MAX+c!

3WA。因为输出格式不对。。。。少了个句点你能信。、。。

4AC

2. 我们来算一下时间复杂度吧。你在读数据后遍历的时候, 两层for循环到n,所以时间复杂度是n^2的还可以。加一个克鲁斯科尔 排序 o(eloge)+遍历o(e)的。

【POJ - 1789】【ZOJ - 2158】【SCU - 1832】Truck History (最小生成树)相关推荐

  1. poj 1789 Truck History(最小生成树 prim)

    题目:http://poj.org/problem?id=1789 大意:每个卡车都有自己的编号,由七位字母组成 d(to,td) is the distance of the types指t0 和 ...

  2. POJ-1789 Truck History 最小生成树

    计算整个汽车演化过程中所要改变的最少的字符数.改变的字符数的计算方式为1-7位不同位的个数. 代码如下: #include <cstdlib> #include <cstring&g ...

  3. Kuskal/Prim POJ 1789 Truck History

    题目传送门 题意:给出n个长度为7的字符串,一个字符串到另一个的距离为不同的字符数,问所有连通的最小代价是多少 分析:Kuskal/Prim: 先用并查集做,简单好写,然而效率并不高,稠密图应该用Pr ...

  4. (最小生成树)Truck History --POJ -- 1789

    链接: http://poj.org/problem?id=1789 Time Limit: 2000MS   Memory Limit: 65536K Total Submissions: 2213 ...

  5. POJ 1789 Truck History

    最小生成树问题. 给你一组字母序列,问你最有可能的演变,也就是把全部的序列连通所花费最小. 每次派生的花费 取决于两个字符串上 不同的字母个数. 于是两两算出花费,然后Kruskal算最小. #inc ...

  6. 【POJ】【最小生成树】1789 Truck History

    1 思路 题目链接. 最小生成树(MST)问题. 2 代码 代码来自宇宙吾心博客. #include <iostream> #include <limits> #include ...

  7. POJ - 1789 Truck History (最小生成树)

    https://vjudge.net/problem/POJ-1789 题意 n个车牌,长度固定为7,车牌与车牌间的距离为不同字母个数.问所有车牌形成一棵树的最小边权和是多少. 分析 最小生成树模板 ...

  8. POJ,ZOJ题目分类(多篇整合版,分类很细致,全面)

    水题: 3299,2159,2739,1083,2262,1503,3006,2255,3094 初级: 一.基本算法:        (1)枚举 (1753,2965)       (2)贪心(13 ...

  9. poj 3487 zoj 1576 稳定婚姻

    两题都是基础题,不同的是 zoj 那题的男女可能重名. Gale-Shapley 算法: while ( 存在男人m是自由的 ) { 令w是m的还没求过婚的最高排名的女人 if ( w是自由的 )   ...

最新文章

  1. 083、Prometheus架构(2019-05-05 周日)
  2. 图挖掘与多关系学习:工具与应用,亚马逊与CMU-WWW2021教程(附ppt)
  3. MBTI职业性格测试结果——ISTJ型
  4. SAP BTP 平台 CloudFoundry 环境下编程概述
  5. java transferto_小六六学Netty系列之Java 零拷贝
  6. 天津市七下计算机课程,七年级下册信息技术课程教案.doc
  7. PAT乙级1028 人口普查 (20 分)
  8. 各版本Sql Server下载地址全
  9. Linux基本命令总结(初学者可以借鉴学习)
  10. 系统之家 linux下载,迅雷Linux版下载_迅雷Linux版官方版1.0.0.1 - 系统之家
  11. python儿童编程入门-如何让孩子轻松学习Python编程
  12. 携程酒店价格关键信息记录
  13. 如何用C语言编程序化交易,程序化交易的开发步骤
  14. ps4 优酷 html5,ps4-hen-vtx/index.html at master · xvortex/ps4-hen-vtx · GitHub
  15. EAX、EBX、ECX、EDX、ESI、EDI、ESP、EBP 寄存器详解
  16. 2020清华大学计算机学院黄翔,清华大学计算机科学与技术系2020—2021学年度学生会主席候选人名单公示...
  17. 257套工业机器人SW设计3D图纸焊接机械手/发那科ABB安川臂模型
  18. 微服务: 想办法让项目运行起来
  19. ZigBee协议栈浅显解读(一)
  20. 【计量经济学】时间序列分析笔记 Models with Trend

热门文章

  1. linux系统命令光标移动,Linux 命令行 光标移动技巧及利用grep和find查找文件内容...
  2. 搭载鸿蒙的油烟机,华为、美的合作:搭载鸿蒙系统的家电来了 三大亮点
  3. mysql集群和主从区别_搭建MySQL主从集群,主从复制过程中同步延迟问题
  4. RT-Thread使用ENV生成工程时自己添加的文件被清掉的解决方法
  5. windows 7搭建流媒体服务
  6. java切面1.6需要的包_Java技术 AspectJ
  7. [Qt] 利用QtWebKit完成JavaScript访问C++对象
  8. 10以内的分解与组成怎么教_【一年级数学】(上)10以内的分与合技巧及练习题...
  9. 运营管理整改报告范文_整改报告 反馈问题整改报告范文精选5篇
  10. MySQL——基本配置