一、场景设置
 
说明:R1 Serial1/0 R2  Serial1/1R3  Serial1/0  R4。需要在RB上配置路由再分配。
 
二、具体配置
 
1、RA的配置如下:
Router(config)#hostname RA
RA(config)#interface Loopback0
RA(config-if)#ip address 1.1.1.1 255.255.255.0
RA(config-if)#ip ospf network point-to-point
RA(config-if)#exit
RA(config)#interface Serial1/0
RA(config-if)#ip address 199.99.1.1 255.255.255.0
RA(config-if)#no shutdown
RA(config-if)#exit
RA(config)#router rip
RA(config-router)#version 2
RA(config-router)#network 1.0.0.0
RA(config-router)#network 199.99.1.0
RA(config-router)#exit
 
2、RB的配置如下:
Router(config)#hostname RB
RB(config)#interface Loopback0
RB(config-if)#ip address 2.2.2.2 255.255.255.0
RB(config-if)#ip ospf network point-to-point
RB(config-if)#exit
RB(config)#interface Serial1/0
RB(config-if)#ip address 199.99.1.2 255.255.255.0
RB(config-if)#no shutdown
RB(config-if)#exit
RB(config)#interface Serial1/1
RB(config-if)#ip address 199.99.2.1 255.255.255.0
RB(config-if)#no shutdown
RB(config-if)#exit
RB(config)#router ospf 1
RB(config-router)#redistribute rip subnets
RB(config-router)#network 199.99.2.0 0.0.0.255 area 0
RB(config-router)#network 2.2.2.0 0.0.0.255 area 0
RB(config-router)#exit
RB(config)#router rip
RB(config-router)#version 2
RB(config-router)#redistribute ospf 1 metric 2
RB(config-router)#network 199.99.1.0
RB(config-router)#no auto-summary
RB(config-router)#exit
 
3、RC的配置如下:
RC(config)#hostname RC
RC(config)#interface Loopback0
RC(config-if)#ip address 3.3.3.3 255.255.255.0
RC(config-if)#ip ospf network point-to-point
RC(config-if)#exit
RC(config)#interface Serial1/1
RC(config-if)#ip address 199.99.2.2 255.255.255.0
RC(config-if)#no shutdown
RC(config-if)#exit
RC(config)#interface Serial1/0
RC(config-if)#ip address 199.99.3.1 255.255.255.0
RC(config-if)#no shutdown
RC(config-if)#exit
RC(config)#router ospf 1
RC(config-router)#network 3.3.3.0 0.0.0.255 area 1
RC(config-router)#network 199.99.2.0 0.0.0.255 area 0
RC(config-router)#network 199.99.3.0 0.0.0.255 area 1
RC(config-router)#exit
 
4、RD的配置如下:
Router(config)#hostname RD
RD(config)#interface Loopback0
RD(config-if)#ip address 4.4.4.4 255.255.255.0
RD(config-if)#ip ospf network point-to-point
RD(config-if)#exit
RD(config)#interface Serial1/0
RD(config-if)#ip address 199.99.3.2 255.255.255.0
RD(config-if)#no shutdown
RD(config-if)#exit
RD(config)#router ospf 1
RD(config-router)#network 4.4.4.0 0.0.0.255 area 1
RD(config-router)#network 199.99.3.0 0.0.0.255 area 1
RD(config-router)#exit
 
三、验证配置
 
1、查看各路由器相关接口的开启状态:
 
RA#show ip interface brief
Interface                  IP-Address      OK? Method        Status         Protocol
Serial1/0                  199.99.1.1        YES manual        up                up
Loopback0                1.1.1.1              YES manual        up                up
 
RB#show ip interface brief
Interface                  IP-Address      OK? Method        Status         Protocol
Serial1/0                  199.99.1.2        YES  manual       up                 up
Serial1/1                  199.99.2.1        YES  manual       up                 up
Loopback0                2.2.2.2              YES  manual       up                 up
 
RC#show ip interface brief
Interface                  IP-Address      OK? Method         Status         Protocol
Serial1/0                  199.99.3.1        YES manual         up                up
Serial1/1                  199.99.2.2        YES manual         up                up
Loopback0                3.3.3.3              YES manual         up                up
 
RD#show ip interface brief
Interface                  IP-Address      OK? Method         Status          Protocol
Serial1/0                  199.99.3.2        YES manual         up                 up
Loopback0                4.4.4.4              YES manual         up                 up
 
可见相关的接口及链路协议已经处于开启状态!
 
2、查看各路由器的路由表:
 
RA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
     1.0.0.0/24 is subnetted, 1 subnets
C       1.1.1.0 is directly connected, Loopback0
     2.0.0.0/24 is subnetted, 1 subnets
R       2.2.2.0 [120/2] via 199.99.1.2, 00:00:17, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
R       3.3.3.0 [120/2] via 199.99.1.2, 00:00:17, Serial1/0
     4.0.0.0/24 is subnetted, 1 subnets
R       4.4.4.0 [120/2] via 199.99.1.2, 00:00:17, Serial1/0
R    199.99.3.0/24 [120/2] via 199.99.1.2, 00:00:17, Serial1/0
R    199.99.2.0/24 [120/2] via 199.99.1.2, 00:00:17, Serial1/0
C    199.99.1.0/24 is directly connected, Serial1/0
 
RB#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
R    1.0.0.0/8 [120/1] via 199.99.1.1, 00:00:01, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
C       2.2.2.0 is directly connected, Loopback0
     3.0.0.0/24 is subnetted, 1 subnets
O IA    3.3.3.0 [110/65] via 199.99.2.2, 00:09:57, Serial1/1
     4.0.0.0/24 is subnetted, 1 subnets
O IA    4.4.4.0 [110/129] via 199.99.2.2, 00:05:15, Serial1/1
O IA 199.99.3.0/24 [110/128] via 199.99.2.2, 00:06:06, Serial1/1
C    199.99.2.0/24 is directly connected, Serial1/1
C    199.99.1.0/24 is directly connected, Serial1/0
 
RC#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
O E2 1.0.0.0/8 [110/20] via 199.99.2.1, 00:06:10, Serial1/1
     2.0.0.0/24 is subnetted, 1 subnets
O       2.2.2.0 [110/65] via 199.99.2.1, 00:07:01, Serial1/1
     3.0.0.0/24 is subnetted, 1 subnets
C       3.3.3.0 is directly connected, Loopback0
     4.0.0.0/24 is subnetted, 1 subnets
O       4.4.4.0 [110/65] via 199.99.3.2, 00:06:10, Serial1/0
C    199.99.3.0/24 is directly connected, Serial1/0
C    199.99.2.0/24 is directly connected, Serial1/1
O E2 199.99.1.0/24 [110/20] via 199.99.2.1, 00:06:10, Serial1/1
 
RD#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
O E2 1.0.0.0/8 [110/20] via 199.99.3.1, 00:06:56, Serial1/0
     2.0.0.0/24 is subnetted, 1 subnets
O IA    2.2.2.0 [110/129] via 199.99.3.1, 00:06:56, Serial1/0
     3.0.0.0/24 is subnetted, 1 subnets
O       3.3.3.0 [110/65] via 199.99.3.1, 00:06:56, Serial1/0
     4.0.0.0/24 is subnetted, 1 subnets
C       4.4.4.0 is directly connected, Loopback0
C    199.99.3.0/24 is directly connected, Serial1/0
O IA 199.99.2.0/24 [110/128] via 199.99.3.1, 00:06:56, Serial1/0
O E2 199.99.1.0/24 [110/20] via 199.99.3.1, 00:06:56, Serial1/0
 
3、在运行了OSPF协议的路由器查看邻居:
 
RB#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3                0      FULL/  -       00:00:38       199.99.2.2      Serial1/1
 
RC#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
2.2.2.2                0      FULL/  -       00:00:31       199.99.2.1      Serial1/1
4.4.4.4                0      FULL/  -       00:00:34       199.99.3.2      Serial1/0
RD#show ip ospf neighbor
Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3                0      FULL/  -       00:00:33       199.99.3.1      Serial1/0
 
4、在运行了OSPF协议的路由器查看OSPF数据库:
 
RB#show ip ospf database
            OSPF Router with ID (2.2.2.2) (Process ID 1)
                Router Link States (Area 0)
Link ID      ADV Router      Age        Seq#              Checksum  Link  count
2.2.2.2         2.2.2.2                776         0x80000004   0x00D838   3
3.3.3.3         3.3.3.3                772         0x80000002   0x00DC49  2
                Summary Net Link States (Area 0)
Link ID      ADV Router      Age        Seq#              Checksum
3.3.3.0         3.3.3.3                780         0x80000001   0x00CC5A
4.4.4.0         3.3.3.3                481         0x80000001   0x002BB8
199.99.3.0      3.3.3.3             532         0x80000001   0x00C2FF
                Type-5 AS External Link States
Link ID      ADV Router      Age         Seq#              Checksum   Tag
1.0.0.0         2.2.2.2                1328        0x80000001   0x009EF8     0
199.99.1.0      2.2.2.2             1328        0x80000001   0x00D299     0
 
RC#show ip ospf database
            OSPF Router with ID (3.3.3.3) (Process ID 1)
                Router Link States (Area 0)
Link ID      ADV Router      Age        Seq#               Checksum   Link  count
2.2.2.2         2.2.2.2                791         0x80000004    0x00D838    3
3.3.3.3         3.3.3.3                786         0x80000002    0x00DC49   2
                Summary Net Link States (Area 0)
Link ID      ADV Router      Age        Seq#               Checksum
3.3.3.0         3.3.3.3                794         0x80000001    0x00CC5A
4.4.4.0         3.3.3.3                494         0x80000001    0x002BB8
199.99.3.0      3.3.3.3             545         0x80000001    0x00C2FF
                Router Link States (Area 1)
Link ID      ADV Router      Age        Seq#               Checksum  Link count
3.3.3.3         3.3.3.3                509         0x80000004    0x0010F0    3
4.4.4.4         4.4.4.4                508         0x80000003    0x000FEB   3
                Summary Net Link States (Area 1)
Link ID      ADV Router      Age        Seq#               Checksum
2.2.2.0         3.3.3.3                779         0x80000001    0x007376
199.99.2.0      3.3.3.3             809         0x80000001    0x00CDF5
                Summary ASB Link States (Area 1)
Link ID      ADV Router      Age        Seq#               Checksum
2.2.2.2         3.3.3.3                799         0x80000001    0x0047A0
                Type-5 AS External Link States
Link ID      ADV Router      Age         Seq#              Checksum  Tag
1.0.0.0         2.2.2.2                1363        0x80000001   0x009EF8    0
199.99.1.0      2.2.2.2             1365        0x80000001   0x00D299    0
 
RD#show ip ospf database
            OSPF Router with ID (4.4.4.4) (Process ID 1)
                Router Link States (Area 1)
Link ID      ADV Router      Age        Seq#               Checksum   Link   count
3.3.3.3         3.3.3.3                523         0x80000004    0x0010F0     3
4.4.4.4         4.4.4.4                522         0x80000003    0x000FEB    3
                Summary Net Link States (Area 1)
Link ID      ADV Router      Age        Seq#               Checksum
2.2.2.0         3.3.3.3                793         0x80000001    0x007376
199.99.2.0      3.3.3.3             803         0x80000001    0x00CDF5
                Summary ASB Link States (Area 1)
Link ID      ADV Router      Age         Seq#              Checksum
2.2.2.2         3.3.3.3                793          0x80000001   0x0047A0
                Type-5 AS External Link States
Link ID      ADV Router      Age         Seq#              Checksum  Tag
1.0.0.0         2.2.2.2                1357        0x80000001   0x009EF8    0
199.99.1.0      2.2.2.2             1359        0x80000001   0x00D299    0
 
 

 
本文出自 “Uione” 博客,请务必保留此出处http://weiqijun.blog.51cto.com/338163/74340

转载于:https://blog.51cto.com/973503/211266

多区域OSPF的路由重发布相关推荐

  1. 网络工程师提高篇 | 路由重发布你了解多少?从原理到配置,瑞哥带你学习一波!

    文章目录 技术背景 实施要点 路由优先级问题 路由倒灌 路由重发布的配置 OSPF与RIP的互重发布 重发布直连路由到OSPF 重发布静态路由到OSPF 技术背景 在同一个网络拓扑结构中,如果存在两种 ...

  2. 引入静态路由_网络工程师提高篇 | 路由重发布你了解多少?从原理到配置,瑞哥带你学习一波!...

    技术背景 实施要点 路由优先级问题 路由倒灌 路由重发布的配置 OSPF与RIP的互重发布 重发布直连路由到OSPF 重发布静态路由到OSPF 技术背景 在同一个网络拓扑结构中,如果存在两种不同的路由 ...

  3. HCIP路由重发布技术以及路由策略及配置---RIP与OSPF双向重发布

    目录 1.重发布技术的概述 2.重发布技术的条件: 3.重发布技术的规则: 4.重发布技术的名词解释: 5.RIP单点重发布技术与配置 6.OSPF重发布技术与配置 7.多点双向重发布产生的问题--- ...

  4. vyos-vyatta在ospf和bgp之间路由重发布使用 打tag形式进行路由过滤

    在ospf和bgp之间路由重发布使用 打tag形式进行路由过滤 set policy route-map BGP-ROUTE-01 rule 100 set tag '4444' set policy ...

  5. CCNP路由实验之八 路由重发布

     CCNP路由实验之八 路由重发布 在前面几个实验,已经学习了静态路由和动态路由.现在,我们要掌握如何使它们在一个网络中融合,即路由重发布.路由重分布可以实现多种路由协议之间共享路由信息并进行路由 ...

  6. ripv2ospf路由重发布

    ripv2&ospf路由重发布 拓扑图 要求 如上拓扑图,左侧路由使用ospf协议,右侧使用ripv2协议,让网络全网互通. 1. 在各个路由器上配置网络ip AR0 [Huawei-Seri ...

  7. CCNP-22 路由重发布2(BSCI)

    CCNP-22 路由重发布2 实验拓扑: 实验要求:R1与R2之间采用RIP路由协议,R3与R2之间采用EIGRP路由协议,要使R1和R3能够相互学习到对方的路由. 试验目的:掌握RIP与EIGRP路 ...

  8. 实验六:路由重发布配置

    1.实验拓扑图 2.实验目的 1)理解路由重发布的概念及作用 2)掌握路由重发布的配置方法 配置各路由器接口IP地址 R0 s0/1/0 192.168.12.1 Loopback 192.168.1 ...

  9. 锐捷BGP基础配置(邻居建立、路由重发布、路由聚合、认证)

    目录 配置IBGP邻居 配置EBGP邻居 配置BGP重发布OSPF BGP路由聚合 BGP其它配置 配置IBGP邻居 R2.R3.R4底层IGP互通,此处IGP互通配置不做介绍 R2与R4通过Loop ...

最新文章

  1. json对象转为url参数_Day48_Ajaxamp;Json
  2. 2022年了,PyTorch和TensorFlow选哪个?
  3. 剑指offer面试题6:重建二叉树
  4. Linux查看utmp文件,linuxc操作utmp和wtmp文件接口
  5. SAP Fiori My task里complete checkbox的处理
  6. 【UIKit】UITableView 3
  7. Java Object有哪些公用方法?
  8. oracle检查外键依赖,Oracle中检查外键是否有索引的SQL脚本分享
  9. java中常用的坑_Java技术开发中的坑
  10. iOS通过iTunes search检测版本更新,并提示用户更新!
  11. 开课吧:浅析人工智能对网络安全格局的影响
  12. 数组成员是函数java_在Laravel 5.6中调用数组上的成员函数links()
  13. 【转载】谈谈自己对REST、SOA、SOAP、RPC、ICE、ESB、BPM知识汇总及理解
  14. bsvadvaanjalvsc
  15. 初学者-C语言基础练习(二)——C语言编译器的使用方法
  16. 诚风老师-直销立法十年 直销企业迎来新机遇
  17. 论文|Jointly Pre-Training Transformers on Unpaired Images and Text
  18. 从浏览器中打开我们的应用
  19. 读易[14]·远古卜卦算法分析与实现
  20. c:if标签多条件的逻辑判断

热门文章

  1. WEB交互的划时代革新--HTML5中WebSocket应用【1】
  2. 转]Linux杀死进程方法大全
  3. 读取PDF的文字--zt
  4. SpringCloud 使用Docker搭建Consul节点集群
  5. 如何动态在maven插件中加载项目及第三方类
  6. 工作实践之 try-with-resource 资源关闭
  7. webrtc之onicecandidate的 event handler的一点疑惑
  8. Assemby 打包并启动jar包
  9. 上传jar包到私服(仅限于翼支付公司工作流程使用)和涉及的技术总结
  10. centos上安装和配置tomcat