描述:
area 0做ospf区域验证,area23做ospf接口认证。
R1#sh run
Building configuration...
Current configuration : 2677 bytes
!
version 12.4
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 20.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 20.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 20.1.3.1 255.255.255.0
!
interface Loopback4
 ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/1
 ip address 192.168.18.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.12.1 255.255.255.0
 encapsulation frame-relay
 ip ospf authentication-key cisco
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.12.2 102 broadcast
 no frame-relay inverse-arp
!
interface Serial1/1.145 multipoint
 ip address 192.168.145.1 255.255.255.0
 snmp trap link-status
 frame-relay map ip 192.168.145.5 115 broadcast
 frame-relay map ip 192.168.145.4 114 broadcast
!
router ospf 1
 router-id 1.1.1.1
 log-adjacency-changes
 area 0 authentication message-digest
 area 0 range 20.1.0.0 255.255.252.0
 area 18 virtual-link 8.8.8.8 authentication authentication-key cisco
 area 145 nssa no-redistribution default-information-originate metric 100 metric-type 1 no-summary
 redistribute connected metric 100 metric-type 1 subnets route-map CONNECT
 network 1.1.1.1 0.0.0.0 area 0
 network 20.1.1.1 0.0.0.0 area 0
 network 20.1.2.1 0.0.0.0 area 0
 network 20.1.3.1 0.0.0.0 area 145
 network 192.168.12.1 0.0.0.0 area 0
 network 192.168.18.1 0.0.0.0 area 18
 network 192.168.145.1 0.0.0.0 area 145
 neighbor 192.168.12.2
 neighbor 192.168.145.4
 neighbor 192.168.145.5
!        
route-map CONNECT permit 10
 match interface Loopback4
!
end
 
 
 
R2#sh run
Building configuration...
Current configuration : 2149 bytes
!
version 12.4
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback1
 ip address 172.16.2.1 255.255.255.0
    
interface FastEthernet0/1
 ip address 192.168.28.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0
 ip address 192.168.12.2 255.255.255.0
 encapsulation frame-relay
 ip ospf authentication-key cisco
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.12.1 201 broadcast
 no frame-relay inverse-arp
!
interface Serial1/1
 ip address 192.168.23.2 255.255.255.0
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.23.3 213 broadcast
 no frame-relay inverse-arp
!
router eigrp 100
 network 172.16.2.0 0.0.0.255
 no auto-summary
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 area 0 authentication message-digest
 area 0 range 20.1.0.0 255.255.252.0
 area 23 stub no-summary
 area 28 virtual-link 8.8.8.8 authentication authentication-key cisco
 redistribute eigrp 100 metric 100 subnets
 network 2.2.2.2 0.0.0.0 area 0
 network 192.168.12.2 0.0.0.0 area 0
 network 192.168.23.2 0.0.0.0 area 23
 network 192.168.28.2 0.0.0.0 area 28
 neighbor 192.168.23.3
end
 
 
R3#sh run
Building configuration...
Current configuration : 1619 bytes
!
version 12.4
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface Serial1/1
 ip address 192.168.23.3 255.255.255.0
 encapsulation frame-relay
 ip ospf authentication message-digest
 ip ospf message-digest-key 1 md5 cisco
 ip ospf priority 0
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.23.2 312 broadcast
 no frame-relay inverse-arp
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 stub
 network 3.3.3.3 0.0.0.0 area 23
 network 192.168.23.3 0.0.0.0 area 23
!
end
 
 

R4#sh run
Building configuration...
Current configuration : 1594 bytes
!
version 12.4
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface Serial1/1
 ip address 192.168.145.4 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.145.5 411 broadcast
 frame-relay map ip 192.168.145.1 411 broadcast
 no frame-relay inverse-arp
router ospf 1
 router-id 4.4.4.4
 log-adjacency-changes
 area 145 nssa
 network 4.4.4.4 0.0.0.0 area 145
 network 192.168.145.4 0.0.0.0 area 145
!
end
 
 

R5#sh run
Building configuration...
Current configuration : 1822 bytes
!
version 12.4
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.57.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/1
 ip address 192.168.145.5 255.255.255.0
 encapsulation frame-relay
 ip ospf priority 0
 serial restart-delay 0
 no arp frame-relay
 frame-relay map ip 192.168.145.4 511 broadcast
 frame-relay map ip 192.168.145.1 511 broadcast
 no frame-relay inverse-arp
router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
 area 145 nssa
 summary-address 10.1.0.0 255.255.252.0
 redistribute rip metric 100 metric-type 1 subnets
 network 5.5.5.5 0.0.0.0 area 145
 network 192.168.145.5 0.0.0.0 area 145
!
router rip
 version 2
 redistribute ospf 1 metric 5
 network 192.168.57.0
 no auto-summary
end
 
 

R6#sh run
Building configuration...
Current configuration : 1473 bytes
!
version 12.4
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
interface FastEthernet0/1
 ip address 192.168.68.6 255.255.255.0
 duplex auto
 speed auto
router ospf 1
 router-id 6.6.6.6
 log-adjacency-changes
 area 68 stub
 network 6.6.6.6 0.0.0.0 area 68
 network 192.168.68.6 0.0.0.0 area 68
end
 
 

R7#sh run
Building configuration...
Current configuration : 1576 bytes
!
version 12.4
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!        
interface Loopback1
 ip address 10.1.1.1 255.255.255.0
!
interface Loopback2
 ip address 10.1.2.1 255.255.255.0
!
interface Loopback3
 ip address 10.1.3.1 255.255.255.0
!
interface FastEthernet0/1
 no switchport
 ip address 192.168.57.7 255.255.255.0
 speed 10
router rip
 version 2
 network 10.0.0.0
 network 192.168.57.0
 no auto-summary
end
 
 

R8#sh run
Building configuration...
Current configuration : 1828 bytes
!
version 12.4
interface Loopback0
 ip address 8.8.8.8 255.255.255.255
!        
interface FastEthernet0/1
 ip address 192.168.18.8 255.255.255.0
!
interface FastEthernet0/2
 ip address 192.168.28.8 255.255.255.0
        
interface FastEthernet0/3
 ip address 192.168.68.8 255.255.255.0
!
router ospf 1
 router-id 8.8.8.8
 log-adjacency-changes
 area 0 range 20.1.0.0 255.255.252.0
 area 18 virtual-link 1.1.1.1 authentication authentication-key cisco
 area 28 virtual-link 2.2.2.2 authentication authentication-key cisco
 area 68 stub
 network 8.8.8.8 0.0.0.0 area 18
 network 192.168.18.8 0.0.0.0 area 18
 network 192.168.28.8 0.0.0.0 area 28
 network 192.168.68.8 0.0.0.0 area 68
!
end
 
查看校验

转载于:https://blog.51cto.com/matthewyin/216850

OSPF综合(上)---配置相关推荐

  1. ospf综合实验配置

    文章目录 一.题目要求 二.IP地址分配 三.IP地址及其相关配置 四.搭建MGRE环境 五.启动OSPF协议和RIP协议 六.减少LSA的更新量(进行汇总和做特殊区域) 七.加快收敛(可以修改hel ...

  2. vlan 动态ospf综合网络配置

    R2的配置: Router> Router>en Router#conf t Router(config)#int s2/0 Router(config-if)#ip address 19 ...

  3. 华为ensp ospf综合实验

    实验拓扑 ​拓扑下载 华为OSPF综合实验 图 1-1 注:如无特别说明,描述中的 R1 或 SW1 对应拓扑中设备名称末尾数字为 1 的设备,R2 或 SW2 对应拓扑中设备名称末尾数字为 2 的设 ...

  4. 15 路由器综合路由配置

    借鉴网址:Packet Tracer 思科模拟器入门教程 之十四 路由器综合路由配置_柚子君.的博客-CSDN博客_思科模拟器入门教程 姓 名 彭彭头 实验日期 2022.05.17 学 号 实验序号 ...

  5. 思科模拟器 --- 路由器综合路由配置

    学习目标:掌握综合路由器的配置方法.了解路由重分发 1.路由重分发的概念 ①在大型的企业中,可能在同一网内使用到多种路由协议,为了实现多种路由协议的协同工作,路由器可以使用路由重分发(route re ...

  6. 数据通信技术(九:OSPF特殊区域配置(Cisco))

    OSPF单区域配置实验(Cisco) 一.知识准备 1.掌握了OSPF动态路由协议的定义和功能: 2.掌握了OSPF动态路由协议的特征和工作原理. 二.实验目的 1.掌握路由器中OSPF特殊区域STU ...

  7. 数据通信技术(八:OSPF单区域配置实验)

    OSPF单区域配置实验(Cisco) 一.知识准备 1.掌握了OSPF动态路由协议的定义和功能: 2.掌握了OSPF动态路由协议的特征和工作原理. 二.实验目的 掌握OSPF动态路由单区域的基本配置方 ...

  8. ATEN—第十章OSPF的高级配置(4)

    实验使用的工具:小凡模拟器 一.在路由器R1上,配置接口,启动ospf路由进程和rip,宣告网段,并配置路由重分发 ★☆R1☆★☆→ Router> Router>enable Route ...

  9. o oia ospf 路由优先_OSPF基本配置及OSPF特殊区域配置

    一.拓扑 二.OSPF基本配置 1.R1 OSPF配置 router ospf 1 router-id 1.1.1.1 interface Ethernet0/1 ip address 10.1.12 ...

  10. 简单的OSPF多区配置

    简单的OSPF多区配置 完成标准:每个路由器的路由表中都有7个网段的路由,用show  ip  route查看 <?xml:namespace prefix = o ns = "urn ...

最新文章

  1. ASP.NET编程中的十大技巧【转载】
  2. 【机器学习算法-python实现】最大似然估计(Maximum Likelihood)
  3. 关于Javascript闭包的理解
  4. 通过JAVA对HDFS进行操作管理插件
  5. Linux中最受欢迎的邮件传输代理(MTA)
  6. 不擅演讲的马化腾在 08 年讲了什么?
  7. 总结 | 那些里程碑意义的深度学习目标检测论文
  8. Mininet与真实网络链接的方法
  9. C++---vector与list之间的区别
  10. 【超直白】leetcode 279 完全平方数
  11. Struts2学习笔记(六) 结果(Result)(上)
  12. 为GitHub项目加入Travis-CI的自动集成
  13. 第一季度VR市场报告出炉,中国市场份额下降至全球第三
  14. android手机主流屏幕大小,如何选择适合自己的手机屏幕大小 屏幕大小选择标准【详解】...
  15. Snipaste 截图工具
  16. TypeScript基础之类型推断
  17. c++中的有符号数与无符号数一起运算
  18. wpa_supplicant、hostapd编译
  19. 格式化后如何恢复数据?
  20. 读取excel批量生成二维码

热门文章

  1. 全球及中国智能交通行业应用方向分析及创新发展战略报告2021版
  2. 《微机原理及接口技术》第04章在线测试
  3. Animated Eye Candy for Programmers
  4. Appium_pytest fixture的使用
  5. C语言 - sizeof和strlen的区别
  6. postgres安装02--postgis
  7. django Forbidden
  8. 浅谈企业软件架构(5)
  9. 8个秘诀成就顶级增长黑客
  10. 导购的路上,媒体向左,社区向右