题目描述

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M x N grid (1 <= M <= 15; 1 <= N <= 15) of square tiles, each of which is colored black on one side and white on the other side. As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make. Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

约翰知道,那些高智力又快乐的奶牛产奶量特别高.所以他做了一个翻瓦片的益智游戏来娱乐奶牛.在一个M×N(1≤M,N≤15)的骨架上,每一个格子里都有一个可以翻转的瓦片.瓦片的一面是黑色的,而另一面是白色的.对一个瓦片进行翻转,可以使黑变白,也可以使白变黑.然而,奶牛们的蹄子是如此的巨大而且笨拙,所以她们翻转一个瓦片的时候,与之有公共边的相邻瓦片也都被翻转了.那么,这些奶牛们最少需要多少次翻转,使所有的瓦片都变成白面向上呢?如杲可以做到,输出字典序最小的结果(将结果当成字符串处理).如果不能做到,输出“IMPOSSIBLE”.

输入

* Line 1: Two space-separated integers: M and N

* Lines 2..M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white

第1行输入M和N,之后M行N列,输入游戏开始时的瓦片状态.0表示白面向上,1表示黑面向上.

输出

* Lines 1..M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.

输出M行,每行N个用空格隔开的整数,表示对应的格子进行了多少次翻转.

样例输入

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

样例输出

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0OUTPUT DETAILS:
After flipping at row 2 column 1, the board will look like:
0 0 0 1
1 0 1 0
1 1 1 0
1 0 0 1
After flipping at row 2 column 4, the board will look like:
0 0 0 0
1 0 0 1
1 1 1 1
1 0 0 1
After flipping at row 3 column 1, the board will look like:
0 0 0 0
0 0 0 1
0 0 1 1
0 0 0 1After flipping at row 3 column 4, the board will look like:
0 0 0 0
0 0 0 0
0 0 0 0
0 0 0 0Another solution might be:
0 1 1 0
0 0 0 0
0 0 0 0
0 1 1 0
but this solution is lexicographically higher than the solution above.

题解一眼以为是喜闻乐见的每日大暴搜,然后就开心地开始画。这个东西和翻的先后无关,而且每个点翻两次就翻回去了,只会有0和1两种情况。直接按字典序从小到大翻不翻枚举,得到第一个可行解就停止搜索,没有想清楚“步数最少”到底是不是题目要求。稍微剪了剪枝,就直接这么放着了。搜索复杂度比较玄学,也没仔细想,天真地以为这样就差不多了。    所以说我这么信任你你居然是个状压?用二进制枚举第一行的操作,正如《分手是祝愿》一样,每个点被翻偶数次状态与原来相同。用一个矩阵记录一下每个位置被改变了多少次,在翻下一行时要求上一行全部为0,而能改变的上一行只有正对的那个,所以下一行的操作也是可以确定的。推到最后一行,这一系列操作真正正确与否就可以验证了,看它是否使最后一行全部变为0。当搜出了一个可行解,它固然字典序很小,但还要比较操作次数,并且以操作次数小的优先(话说字典序大多数情况下都是用来优中选优的),所以无论如何都要在第一行枚举所有状态。    昨天找规律,今天递推,正解还真是五花八门多种多样丰富多彩惊世骇俗啊……然而真正的dalao们还是能想到解决问题的办法。存在即合理,有题目就会有解法,有偏差就会有错误,我们总是得相信些什么,有所相信才能走下去。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int ans[18],a[18][18],n,m,bf[18][18],res[18],mi,ge;
bool jg,cl;
void init()
{scanf("%d%d",&m,&n);for(int i=1;i<=m;i++)for(int j=1;j<=n;j++)scanf("%d",&a[i][j]);mi=m*n+1;
}
void dt()
{for(int j=n-1;j>=0;j--)if(ans[1]&(1<<j)) {bf[1][n-j]++;bf[1][n-j-1]++;bf[1][n-j+1]++;bf[2][n-j]++;}for(int i=2;i<=m;i++)for(int j=1;j<=n;j++)if((bf[i-1][j]&1)!=a[i-1][j]){ans[i]|=(1<<(n-j));bf[i][j]++;bf[i][j+1]++;bf[i][j-1]++;bf[i+1][j]++;}cl=1;for(int j=1;j<=n;j++)if((bf[m][j]&1)!=a[m][j]){  cl=0;break;}
}
int main()
{init();for(int i=0;i<=(1<<n)-1;i++){memset(bf,0,sizeof(bf));memset(ans,0,sizeof(ans));ans[1]=i;dt();if(cl){jg=1;ge=0;for(int k=1;k<=m;k++)for(int j=0;j<n;j++)if(ans[k]&(1<<j)) ge++;if(ge<mi){for(int k=1;k<=m;k++)res[k]=ans[k];mi=ge;}} }if(jg)for(int i=1;i<=m;i++){for(int j=n-1;j>0;j--){if(res[i]&(1<<j))  printf("1 ");else  printf("0 ");}if(res[i]&1) printf("1\n");else  printf("0\n");}if(!jg) printf("IMPOSSIBLE");return 0;
}

fliptile

食堂知道,那些疲惫又难过的OIer吃得特别多,所以他们很喜欢大暴搜……

转载于:https://www.cnblogs.com/moyiii-/p/7275262.html

Fliptile 翻格子游戏[Usaco2007 Open]相关推荐

  1. bzoj 1647: [Usaco2007 Open]Fliptile 翻格子游戏(枚举)

    1647: [Usaco2007 Open]Fliptile 翻格子游戏 Time Limit: 5 Sec  Memory Limit: 64 MB Submit: 727  Solved: 287 ...

  2. Fliptile 翻格子游戏

    问题 B: [Usaco2007 Open]Fliptile 翻格子游戏 时间限制: 5 Sec  内存限制: 128 MB 题目描述 Farmer John knows that an intell ...

  3. 翻棋子游戏与Nim游戏

    翻棋子游戏: 题意:一个棋盘上每个格子有一个棋子,每次操作可以随便选一个朝上的棋子(x,y),代表第i行第j列的棋子,选择一个形 如(x,b)或(a,y)(其中b < y,a < x)的棋 ...

  4. 浅谈 翻硬币游戏【Nim博弈】

    ACM博客_kuangbin 博弈-翻硬币游戏 hihoCoder 1172 : 博弈游戏·Nim游戏·二 时间限制:10000ms 单点时限:1000ms 内存限制:256MB 描述 Alice和B ...

  5. HDU-3537 Mock Turtles型翻硬币游戏

    题意:<=10^8不定个硬币,给你n<=100个正面朝上的硬币以及他们所在的位置,可任选1/2/3个硬币反转(不必连续),但要求翻的这1/2/3个硬币中的最右侧的一个是正面朝上的,问先手者 ...

  6. 并查集专题(亲戚,格子游戏,银河英雄传说)

    文章目录 序言 正文 亲戚 时间限制: 1000 ms 空间限制: 262144 KB 题目描述 输入 输出 样例输入 样例输出 讲解 Wrong Answer Code Accepted Code ...

  7. HDU 2209 C - 翻纸牌游戏

    C - 翻纸牌游戏 Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u Submit St ...

  8. 【有趣的Python小程序】Python多个简单上手的库制作WalkLattice 走格子游戏 (思路篇)上

    篇写上一个思路篇,那么今天我们就来完成这一项工作 源代码和配套文件 链接: https://caiyun.139.com/m/i?135ClY1yWrSKX 提取码:e4pq 复制内容打开中国移动云盘 ...

  9. 从翻硬币游戏看敏捷开发

    摘要: 敏捷开发还能这么玩? 本文分享自华为云社区<从翻硬币游戏看敏捷开发>,作者:敏捷的小智. 为了推广敏捷开发的理念,很多敏捷教练都会带领团队做一些敏捷小游戏,今天咱们就来聊聊&quo ...

最新文章

  1. 17 Java面试之css
  2. js 操作vuex数据_Vuex 数据状态持久化如何处理?
  3. arduino下载库出错_arduino的I2C通讯 3:驱动1602液晶屏
  4. 深入Bert实战(Pytorch)----fine-Tuning 2
  5. Ubuntu 下安装Beyond Compare 安装解决方案
  6. Java Script 第十节课 Java Script的for循环练习。
  7. 【转】基于DCMTK的DICOM相关程序编写攻略
  8. linux 安装redis2.8.3,Linux及Windows安装Redis(详细)
  9. stl:queue 源码_C ++ STL中的queue :: empty()和queue :: size()
  10. Visual Studio 安装失败
  11. [转]编程语言与宗教
  12. KTHREAD 线程调度 SDT TEB SEH shellcode中DLL模块机制动态获取 《寒江独钓》内核学习笔记(5)...
  13. Tomcat下载——tomcat7、tomcat8、tomcat9官网下载链接
  14. react+clodop打印
  15. UVALive(LA) 4487 Exclusive-OR(带权并查集)
  16. 红帽linux安装中文输入法,Redhat安装中文输入法
  17. 《人生只有一次,去做自己喜欢的事》读书笔记
  18. click和touchmove vue_移动端touch事件影响click事件以及在touchmove添加preventDefault导致页面无法滚动的解决方法...
  19. 面试官:聊一聊SpringBoot服务监控机制
  20. 服务器远程管理(远程桌面(图形) telnet(命令行))

热门文章

  1. 模拟jQuery--获取事件的封装
  2. 4个开源 TCP/IP 栈被曝33个漏洞,数百万智能和工业设备受影响
  3. PIE SDK地图书签
  4. Android权限管理之Permission权限机制及使用
  5. RP2836 板卡信息标识
  6. shell之任务控制
  7. 玩具脚本-----yum源
  8. thrift之TTransport层的堵塞的套接字I/O传输类TSocket
  9. div透明但不导致内容div透明的解决方法
  10. 完全揭秘***利用漏洞***电子邮件系统