配置:
AR1:

#
interface GigabitEthernet0/0/0ip address 10.1.2.1 255.255.255.0
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2
#
interface NULL0
#
interface LoopBack0ip address 10.1.1.1 255.255.255.255
#
ip route-static 10.1.3.0 255.255.255.0 10.1.2.2
ip route-static 10.1.4.0 255.255.255.0 10.1.2.2

AR2:

#
interface GigabitEthernet0/0/0ip address 10.1.2.1 255.255.255.0
#
interface LoopBack0ip address 10.1.1.1 255.255.255.0
#
rip 1version 2network 10.0.0.0
AR3:
#
ip vpn-instance a1ipv4-familyroute-distinguisher 2:2vpn-target 2:2 export-extcommunityvpn-target 2:2 import-extcommunity
#
ip vpn-instance b1ipv4-familyroute-distinguisher 1:1vpn-target 1:1 export-extcommunityvpn-target 1:1 import-extcommunity
#
mpls lsr-id 3.3.3.3
mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0ip binding vpn-instance b1ip address 10.1.2.2 255.255.255.0
#
interface GigabitEthernet0/0/1ip binding vpn-instance a1ip address 10.1.2.2 255.255.255.0
#
interface GigabitEthernet0/0/2ip address 34.1.1.3 255.255.255.0 mplsmpls ldp
#
interface LoopBack0ip address 3.3.3.3 255.255.255.255
#
bgp 1router-id 3.3.3.3peer 5.5.5.5 as-number 1 peer 5.5.5.5 connect-interface LoopBack0#ipv4-family unicastundo synchronizationpeer 5.5.5.5 enable# ipv4-family vpnv4policy vpn-targetpeer 5.5.5.5 enable#ipv4-family vpn-instance a1 import-route rip 1#ipv4-family vpn-instance b1 import-route directimport-route static
#
ospf 1 router-id 3.3.3.3 area 0.0.0.0 network 3.3.3.3 0.0.0.0 network 34.1.1.3 0.0.0.0
#
rip 1 vpn-instance a1undo summaryversion 2network 10.0.0.0import-route bgp
#
ip route-static vpn-instance b1 10.1.1.0 255.255.255.0 10.1.2.1

AR4:

#
mpls lsr-id 4.4.4.4
mpls
#
mpls ldp
#
interface GigabitEthernet0/0/0ip address 45.1.1.4 255.255.255.0 mplsmpls ldp
#
interface GigabitEthernet0/0/1
#
interface GigabitEthernet0/0/2ip address 34.1.1.4 255.255.255.0 mplsmpls ldp
#
interface LoopBack0ip address 4.4.4.4 255.255.255.0
#
ospf 1 router-id 4.4.4.4 area 0.0.0.0 network 4.4.4.4 0.0.0.0 network 34.1.1.4 0.0.0.0 network 45.1.1.4 0.0.0.0
AR5:
#
ip vpn-instance a2ipv4-familyroute-distinguisher 2:2vpn-target 2:2 export-extcommunityvpn-target 2:2 import-extcommunity
#
ip vpn-instance b2ipv4-familyroute-distinguisher 1:1vpn-target 1:1 export-extcommunityvpn-target 1:1 import-extcommunity
#
mpls lsr-id 5.5.5.5
mpls
#
mpls ldp
#
firewall zone Localpriority 15
#
interface GigabitEthernet0/0/0ip address 45.1.1.5 255.255.255.0 mplsmpls ldp
#
interface GigabitEthernet0/0/1ip binding vpn-instance b2ip address 10.1.3.2 255.255.255.0
#
interface GigabitEthernet0/0/2ip address 57.1.1.5 255.255.255.0
#
interface GigabitEthernet2/0/0ip binding vpn-instance a2ip address 10.1.3.2 255.255.255.0
#
interface LoopBack0ip address 5.5.5.5 255.255.255.0
#
bgp 1router-id 5.5.5.5peer 3.3.3.3 as-number 1 peer 3.3.3.3 connect-interface LoopBack0#ipv4-family unicastundo synchronizationpeer 3.3.3.3 enable# ipv4-family vpnv4policy vpn-targetpeer 3.3.3.3 enable#ipv4-family vpn-instance a2 import-route ospf 2#ipv4-family vpn-instance b2 import-route directimport-route static
#
ospf 1 router-id 5.5.5.5 silent-interface GigabitEthernet0/0/2area 0.0.0.0 network 5.5.5.5 0.0.0.0 network 45.1.1.5 0.0.0.0 network 57.1.1.5 0.0.0.0
#
ospf 2 vpn-instance a2import-route bgparea 0.0.0.0 network 10.1.3.0 0.0.0.255
#
ip route-static vpn-instance b2 10.1.4.0 255.255.255.0 10.1.3.1

AR6:

#
interface GigabitEthernet0/0/1ip address 10.1.3.1 255.255.255.0
#
interface LoopBack0ip address 10.1.4.1 255.255.255.0
#
ip route-static 10.1.1.0 255.255.255.0 10.1.3.2
ip route-static 10.1.2.0 255.255.255.0 10.1.3.2
AR7:
#
interface GigabitEthernet0/0/1ip address 10.1.3.1 255.255.255.0
#
interface GigabitEthernet0/0/2ip address 57.1.1.7 255.255.255.0
#
interface LoopBack0ip address 10.1.4.2 255.255.255.0
#
ospf 1 area 0.0.0.0 network 10.1.3.1 0.0.0.0 network 10.1.4.0 0.0.0.255
#
ip route-static 0.0.0.0 0.0.0.0 57.1.1.5

效果图

局域网组网 实验7 MPLS VNP相关推荐

  1. 实验3——无线局域网组网与管理实验

    无线局域网组网与管理实验 文章目录 无线局域网组网与管理实验 前言 一.实验环境及软件介绍 1.实验环境 2.inSSIDer介绍 二.实验过程 1.无线路由器基本配置(以荣耀路由器为例) 2.不同信 ...

  2. 无线局域网组网与管理实验

    无线局域网组网与管理实验 实验目的 1.1人独立完成基础实验,4 人共同完成扩展实验 2.掌握无线路由器配置方法与步骤 3.学习如何根据无线信道质量更换 AP 的信道 实验环境 PC 一台.无线网卡一 ...

  3. 实验三 无线局域网组网与管理实验

    无线网络技术教程第四版实验四 无线局域网组网与管理实验 目录 无线网络技术教程第四版实验四 无线局域网组网与管理实验 1 实验要求和目的 2 实验原理和背景 3 实验环境和软件 4 实验过程和记录 i ...

  4. 计算机网络 综合组网实验

    目录 前言 一.题目 1.1 实验目标 1.2 实验需求 1.3 总体规划 二.组网实现 (1)网络拓扑实现如下: (2)IP地址的规划.各类型设备的IP地址配置如下: (3)路由实现.使用OSPF协 ...

  5. 计算机网络综合组网实验、综合组网实验

    软件学院综合性.设计性实验报告 专业:Java   年级/班级:2019级Java(2)班   2020-2021 学年第 二 学期 课程名称 计算机网络 指导教师 李晓艳 学号 姓名 1928424 ...

  6. 计算机网络模拟校园,计算机网络课程设计-模拟校园网组网实验

    计算机网络课程设计-模拟校园网组网实验 福建农林大学金山学院 信息工程类 课程实习报告 课程名称: 计算机网络 实习题目: 校园网组网方案 姓 名: 严夫 系: 信息与机电工程系 专 业: 计算机科学 ...

  7. 计算机网络模拟校园,计算机网络课程设计模拟校园网组网实验.doc

    计算机网络课程设计模拟校园网组网实验.doc 福建农林大学 金山 学院 信息工程 类 课程实习报告 课程名称: 计算机网络 实习题目: 校园网组网方案 姓 名: 严夫 系: 信息与机电工程系 专 业: ...

  8. VM虚拟机局域网组网配置

    摘要:针对多虚拟机下,通过自定义IP地址的,实现局域网组网方式:本文提供了一种设置方法,主要包括:静态IP设置,网卡开机自启动设置. 一.虚拟机配置 在VM中,设置如下配置,红框框为关键内容配置,主要 ...

  9. 计算机网络 组网试验,计算机网络 路由器组网实验报告.doc

    计算机网络 路由器组网实验报告 昆明理工大学信息工程与自动化学院学生实验报告 ( 2010 -2011 学年 第 1 学期 ) 课程名称:计算机网络 开课实验室: 2010 年12 月21 日 年级. ...

最新文章

  1. npm包全局安装和局部安装,执行包命令有什么不同?
  2. ArrayList的add(E e)方法与扩容
  3. 蓝桥单片机赛题及模拟题代码
  4. python将数据写入Excel
  5. python二级考试真题_全国BIM技能等级考试真题全套(一/二级,全专业,28套)
  6. java取余数的函数_左神算法基础:哈希函数和哈希表
  7. python123平台作业答案循环结构棋盘放米_python练习集100题(1-20)
  8. 记录一下所了解的一些第三开源框架
  9. 深度学习:卷积神经网络从入门到精通
  10. Apache DolphinScheduler 3.0.0 正式版发布!
  11. EditPlus 使用技巧以及快捷键
  12. 7款浏览器新标签页扩展让你的Chrome耳目一新
  13. uniapp app真机测试
  14. 吉米_王:浅谈“并行计算”
  15. 故宫避开人流游玩的 4 个诀窍
  16. 【26】地图可视化:基于 Echarts + Flask 的动态实时地图组件 - 点气泡流向组合区域三级下钻地图
  17. 算法分析课设(四)采用分治法求树中任意两点之间距离小于K的点对及路径
  18. python滑块验证码
  19. 华为交换机配置接口安全
  20. 蛋白粉是智商税?这6类人喝了,一点都不亏

热门文章

  1. Q妹带你赚外快:改bug赚赏金,日入百元小意思
  2. android类小游戏,五款Android平台打僵尸类游戏推荐
  3. 2021微信大数据挑战赛—参赛总结
  4. 逆向分析中的密码学---tea
  5. 惠普的服务器改win7系统,惠普笔记本win8改win7系统设置bios的详细教程
  6. caffe中的decay_mult怎么理解呢?
  7. 英语语法快速入门2--并列句(附思维导图)
  8. 魔兽世界3.3.5 TrinityCore2020年3月22日编译端
  9. html怎么获取audio的状态,HTML5 Audio标签方法和函数API介绍
  10. android 源码管理工具repo